2010/07/16

CSS:: CSS3に対応させるJSライブラリ

IEを除く主要ブラウザはすでにCSS3に対応していますが、世界シェアNo.1のIE6,7,8は全く対応していません。

CSS3に対応させるべくJSライブラリが開発されています。

今回は、2つメモ。
  1. sand-transformなどに対応するJSライブラリ
    sand-transformやbox-shadowなどが可能になるJSライブラリ。
    box-shadowは古典的なやり方でずっとやっていたので助かります。
  2. IE6,7,8でradius、box-shadowに対応するbehaviorスクリプト
    IE6,7,8でCSS3のメイン機能に対応することができます。
    ただし、XHTMLの作りが悪いとうまく動作しない場合があります。
    position周りだと思うんだけど・・・現在どこが原因なのか調査中です。
    簡単に使えるようなので、重宝しそうですね~
スポンサーリンク

スポンサーリンク