2009/03/21

ブラウザ:: Firefox 3.1β3で未対応アドオンを強制使用する

Firefoxも3.1ベータ3が先日DLできるようになり、使用感としては非常に高速表示できる&3.0で最適化しているサイトでは特に不具合がないことが確認できました。
開発しているWebサイトもIE6,IE7,FF3.0で最適化していたので、問題なし!

でも、ベータ版ということもあり、開発用を含めた常時使用しているアドオンが使えない・・・という難点があります。
というわけで、Firefox3.1ベータ3未対応のアドオンを強制使用する方法をご紹介。

1.xpiファイルをDL
2.拡張子をxpiからzipに変更
3.zipファイル内のinstall.rdf(XMLファイル)を解凍
4.install.rdfの最後尾あたりにあるの内容を3.0+に変更。
5.zipファイルに戻し、拡張子をxpiに。
6.FFにD&Dしてインストール。

私が使用している開発に必要なアドオンは現在のところ正常に動作していますが、動作しないものもありますので自己責任ということで。

改変して正常動作したアドオンはこちら。
 ・Web Developer Localization 1.1.6(日本語版)
 ・FireMobileSimulator

※関係ないけど、RoboFormの対応版はこちら

スポンサーリンク

スポンサーリンク